The following packages have unmet dependencies: winehq-stable : Depends: wine-stable

Semasa saya mahu memasang Wine pada Ubuntu 18.04, saya mendapat satu masalah dependencies.

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-stable : Depends: wine-stable (= 3.0.3~bionic)
E: Unable to correct problems, you have held broken packages.

Setelah saya selidik, penyelesaiannya adalah memasang libasound2-plugins:i386

$ sudo apt install libasound2-plugins:i386

Kemudian pasang Wine seperti biasa

$ sudo apt-get install --install-recommends winehq-stable



Leave a Reply

Your email address will not be published. Required fields are marked *